Configuring DHCP pools on Cisco IOS switch

When preparing switches or Labbing, I’ve often found myself searching for configuration examples on configuring DHCP servers on Cisco IOS switches.

Here’s an example for a /24 pool for Lightweight APs on a layer-3 capable switch (3560 or 3650 with IP services). Assuming the WLC management IP is 10.3.3.20. This example creates the pool with a lease time of 4 hours.

enable
configure terminal
ip dhcp pool AP-pool
network 10.1.1.0 255.255.255.0
dns-server 208.67.222.222 208.67.220.220
default-router 10.1.1.1
option 43 hex 0A030314
lease 0 4
exit
ip dhcp excluded-address 10.1.1.1
ip dhcp excluded-address 10.1.1.255
interface vlan 1
ip address 10.1.1.1 255.255.255.0
no shut
exit
interface range gi0/1-4
switchport mode access
switchport access vlan 1
no shut
end
DHCP server on Cisco IOS

Links:
DHCP pool
DHCP with Option 43

This entry was posted in Cisco, Configuration examples, IOS, Switch, WiFi and tagged , , . Bookmark the permalink.

Leave a Reply